MKV GTI P0100 MAF Error Code Repair

I was driving my GTI the other day and noticed the engine was bucking/surging at low RPM. It was fairly intermittent, however the idle was smooth. The next day the check engine light went off, a quick scan of the OBD-II port revealed at P0100 code “Mass Air Flow or Volume Air Flow Sensor Circuit”. I was initially going to clean the MAF sensor, but after reading the VW forums I thought I should check the harness first.

I peeled away the split loom and sure enough there was a break in the ground (brown) and one of the DC voltage lines (yellow).

photo 2

The break occurred right where the harness makes a sharp 90 degree bend.

photo 1

I cut and soldered the wires back together (note to self: buy a cordless soldering iron). Being that this is an under hood repair it will be exposed to a good amount of moisture and needs to be sealed. Since I didn’t have any adhesive lined heat shrink on hand I covered the repair in RTV and slipped a piece of heat shrink over it before hitting it with the heat gun.

After mending the wires I also routed the harness sightly different than factory. Instead of going over the hardpipe and making a sharp bend, I ran the wire under the hardpipe allowing for a larger radius bend.

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s